ad: Morse-1

Kenwood TS590SG w/computer issues

Discussion in 'General Technical Questions and Answers' started by KU3X, May 15, 2016.

ad: L-HROutlet
ad: l-rl
ad: Left-3
ad: HRDLLC-2
ad: MessiPaoloni-1
ad: L-MFJ
ad: Left-2
ad: abrind-2
ad: L-Geochron
  1. KU3X

    KU3X Ham Member QRZ Page

    I’ll try to keep this short as possible.
    Radio, TS 590SG
    Windows 7 -32 bit on my laptop.
    When I use the USB interface to the TS590 SG and try to run the Kenwood rig control software, the software crashes and I get the blue screen. I did uninstall the anti virus software. I can control the radio with HRD using the USB cable, no issues there. If I use the USB and RS232 cable, I can run both HRD and the Kenwood control software without any issues.
    Anybody else have this problem or possible fix?

    Second computer, Windows 10-64 bit desktop.
    Using the USB cable to the 590SG, both HRD and the Kenwood software run but only for a short time and then they loose communications with the radio. If I key the radio it fails instantly. This is not an RFI issue. I can key the radio in SSB, at no power out into a dummy load and it will loose communication with the radio. If I use the RS232 port on the radio, again all works well.
    I use this same cable, USB, to control the TS990S and have no issues, even at 1500 watts out to any antenna. Hence the reason I know it's not an RFI issue.

    The baud rates on both the RS232 and USB are set to 9600. I also went into the control panel / devise manager to confirm the com ports are set to 9600 baud.

    Any suggestions? Anybody else have these issues?

    Barry, KU3X
     
  2. KM4OVH

    KM4OVH Premium Subscriber QRZ Page

    Try using a different USB cable. I have seen some post that weird problems were solved when a new USB cable was tried.
    Andre, KM4OVH


     
  3. KU3X

    KU3X Ham Member QRZ Page

    I tried thee different cables. Actually the first cable was a faulty, brand new, cable. Needless to say, it's in the trash. I then tried two other cables. So far, no luck.
    Do I have three faulty cables? Maybe?
    I am going to keep plugging away only because I want to find out what's going on. For now I'll just use the RS 232 port since it works.

    Barry
     
  4. W8JX

    W8JX Ham Member QRZ Page

    Blue screen of death is from a serious program code issue or a memory error.

    On baud rate try 19200 and using hardware flow control 8 N 1. Make sure rig and comport is set for correct speed.
     
  5. KA9JLM

    KA9JLM Ham Member QRZ Page

    It does sound like a memory error, On the 7 machine.

    With everything running it uses most of the memory, Then swaps it out to the HD. It could be a HD error too.

    I would start by cleaning / re-seating the memory modules.
     
    Last edited: May 16, 2016
  6. KU3X

    KU3X Ham Member QRZ Page

    Then my question would be, "why does it work with the USB / RS 232 adaptor and only fail on the USB only port on the Windows 7 computer?" Remember, it looses
    communication with the 590 on the Win 10 computer as well and that has 8 GIG of RAM.
    My biggest problem is when it comes to understanding this problem is it works on RS 232 but not USB. RS232 being a USB to RS 232 adaptor.
    This one's driving me nuts !
    Three bad USB cables? The one cable I am using came with the RG Expert AA-600 and it works fine with it.
    Barry
     
  7. KA9JLM

    KA9JLM Ham Member QRZ Page

    What USB drivers do you use with the radios USB-B port ?
     
  8. KC9ZHR

    KC9ZHR Ham Member QRZ Page

    how long is the cable?...I had issues with my ts480 when using too long of a cable...If I transmitted I would loose connection to the radio and ARCP480 would lock up. USB's specs are for VERY short cable runs without hubs/repeaters in line(very finicky about latency in this type of application as well). My run was about 25ft when I had problems. I then placed 2 cables(about 12 feet each) with a usb hub at the half way point. Then I would not lose connection.
     
  9. WA6SW

    WA6SW Ham Member QRZ Page

  10. KE0RG

    KE0RG XML Subscriber QRZ Page

    Have you tried:

    A: Grounding the radio?
    C: Disconnecting every other accessory / peripheral device from both the radio and the computer (just to rule them out as having a detrimental effect)?
    B: Using the same power source for both the computer and the radio... and EVERYTHING else that is connected to BOTH?

    It sounds to me like part of the issue might be with current induced between the devices through the USB port.

    But that blue screen could be many other things - As mentioned previously, I would check the memory and hard drive for problems first -- see if the computer has hardware diagnostics tests from the factory already installed and selectable during the boot process.
     

Share This Page