ad: MyersEng-1

Kenwood TS590 SG has terrible TX audio apparently?

Discussion in 'Amateur Radio Equipment Reviews' started by OK8EI, Jul 28, 2021.

ad: L-HROutlet
ad: l-rl
ad: MessiPaoloni-1
ad: HRDLLC-2
ad: L-MFJ
ad: Left-3
ad: abrind-2
ad: Left-2
ad: L-Geochron
  1. OK8EI

    OK8EI Ham Member QRZ Page

    It turns out that it was just an annoying operator who worships his Icom equipment only, and talks absolute nonsense about everything else from other manufacturers. I have heard him since talking similar rubbish to others on the bands and actually splurting everywhere with his homebrew amplifier. The likes of an operator as such puts me off the hobby a bit.
    I have since purchased an Kenwood TS 590SG . Together with the right TX audio and processor settings, and together with an MC-90A microphone, it sounds excellent.
     
    KU3X, KS2G and WD5GWY like this.
  2. NM7G

    NM7G Ham Member QRZ Page

    I'd consider another possibility..... a manufacturing defect. Folks on a production line do occasionally screw up. It happens, as with my three Kenwood TS930S xcvrs. One and only one of the three had a chronic oscillation (a weak but annoying whine) when the audio filter was ON. Ultimately I found that a polarized capacitor was installed with reversed polarity in the whining 930.

    So, and this is only one opinion, I believe there may be some good and some bad radios bearing the same model number.
     
    KA2MWS likes this.
  3. N1FM

    N1FM Ham Member QRZ Page

  4. M3AIN

    M3AIN QRZ Member

    Sorry to bump an older topic, but as there are a few TS-590SG owners here, I wonder if you'd be so kind as to help me see if there's a problem with my rig?

    In FM mode, when the processor is engaged, recipients are reporting that my audio is very quiet.

    When the speech processor isn't engaged, my audio is reported to be an acceptable volume.

    Is the aforementioned symptom a fault, oversight from Kenwood, or normal behaviour for this Transceiver?

    73
     
  5. KS2G

    KS2G Premium Subscriber QRZ Page

    You need to properly adjust the Speech Processor level.
    Check you Instruction Manual.
    In the manual for my '590S the procedure is on page 31.
     

Share This Page

ad: hrd-2