Kenwood TS-590s & Linux Rig Control Issues

Discussion in 'Ham Radio Discussions' started by W8APP, Oct 14, 2017.

ad: L-HROutlet
ad: l-rl
ad: L-Geochron
ad: MessiPaoloni-1
ad: L-MFJ
ad: Left-3
ad: abrind-2
ad: HRDLLC-2
ad: Left-2
  1. W8APP

    W8APP Ham Member QRZ Page

    I am hoping that someone with a whole lot more knowledge with Linux and rig control can help me out here.

    I have my TS-590s working just fine with rig control using a mac computer and Flrig but I need to get it working on a different computer. My setup is Ubuntu Budgie 17.04 with CQRLOG. No matter what I do I can't see the radio. My interconnect between the two units is a single usb cable that has been confirmed as good. I have also granted dial out permission and have confirmed /dev/ttyUSB0. I confirmed the serial settings the radio wants to see... still no luck. Can anyone help me out?


    Anthony
    KD8QWH
     
  2. KK5JY

    KK5JY Ham Member QRZ Page

    How did you determine that the port created was /dev/ttyUSB0?

    Which type of fldigi control are you running? Whichever it is, make sure to copy over all the settings, including all the checkboxes.

    I also use a 590SG + fldigi + Linux, so feel free to send me a PM if you would like some details from my setup.
     
  3. WJ4U

    WJ4U Subscriber QRZ Page

  4. W8APP

    W8APP Ham Member QRZ Page

    on the linux box I ran a command in terminal that showed me which USB port was created. (I was given direction on how to do that) I am using the CAT control. I have duplicated all my setting over. I think the problem is the device settings. I have tried every available option that it gives me with no luck. Any additional information you can provide is very much appreciated.

    73'

    Anthony
    KD8QWH


     
  5. KK5JY

    KK5JY Ham Member QRZ Page

    This is what I am using for flrig... my 590 isn't connected, so the port shows as "None," but you could just put your local port name there:

    upload_2017-10-14_19-37-43.png

    I have run this configuration on several different machines, including Ubuntu and Raspbian. Many distributions package an old (really old) version of hamlib, so I have upgraded all my machines to 3.1 or later, and removed the stock version.
     
  6. W8APP

    W8APP Ham Member QRZ Page

    Matt,

    Would the setting be the same in FLDIGI?

    I set it up exactly as you have it except for the TS-590s rig and still nothing.
     
  7. W8APP

    W8APP Ham Member QRZ Page

    Okay... I don't know what happened but the radio and the computer are now talking to each other. I shut everything down again and gave it a swift kick in the processor. I now will see if I can get Fldigi working with it.
     
  8. WJ4U

    WJ4U Subscriber QRZ Page

    Are you sure you aren't running Windows variant? ;)
     
  9. KK5JY

    KK5JY Ham Member QRZ Page

    Well, fldigi has more options. Here are my settings from fldigi, again linked against hamlib 3.1:

    upload_2017-10-14_20-55-42.png
    Something to keep in mind is that the TS590 provides more than one virtual TTY device to the host computer, so make sure to check the dmesg output to see if it allocated two devices. It could be that you are simply picking the wrong one. Note that in my configuration, I had to use USB1, since USB0 was for the other function (can't remember what it is, but I didn't care about it, whatever it was).

    Also, make sure that "Use hamlib" is checked at the top (mine isn't because my radio isn't hooked up).
     
  10. W8APP

    W8APP Ham Member QRZ Page

    Thanks for all the support! I have Fldigi working now as well. What is interesting is the /Dev/tty/..... string I had to use to make them talk was not one of the choices that was available to me the first several times I tried it. All is good now.

    Today's goal is too get CQRLog working. That's what I first tried to get working but since I got nowhere with it, I moved to the Floor tools

    Anthony
    KD8QWH
     
    KK5JY and KA9JLM like this.

Share This Page

ad: expert-3