Kenwood TM-V71 and audio via data-port

Discussion in 'Tips and Tricks' started by TJNII, Nov 29, 2021.

ad: L-HROutlet
ad: l-rl
ad: Left-2
ad: Left-3
ad: abrind-2
ad: L-Geochron
ad: L-MFJ
  1. TJNII

    TJNII QRZ Member

    I've just spent a few hours trying to get my TM-V71 to transmit audio from my computer. Here's a few high points I learned to help others. This post is specifically about audio via a PG-5H cable: https://www.amazon.com/Wirenest-Echolink-Kenwood-TM-D710-TM-V71/dp/B01GQF561U The PG-5G serial cable is required as well.

    • Audio will be on the "D" side of the radio, the right side by default.
    • Audio from the radio to the computer should "just work". Try this first. (A good idea anyway as it's just opening squelch)
    • The transmit audio input is mono. Make sure you have audio on the correct channel.
    • I recommend having headphones on test-probes handy to test audio out the sound card and out the cable.
    • The manual has pinouts of the connector, which is useful to make sure audio is coming through on the correct pin: https://www.manualslib.com/manual/679431/Kenwood-Tm-V71a.html?page=98#manual
    • PTT will not enable transmission of audio from the cable
    • To transmit the radio needs to be in "echolink sysop" mode. (Manual page 61, PF2 & Power to enable). When enabled the serial RTS control line enables transmit. (In this mode CTS is squelch state)
    • Do not use the serial PTT command, such as https://github.com/larsks/tm-v71-tools#ptt This will only give a hot-mic and not repeatably enable transmission of audio from the computer. I found the echolink sysop mode to be much more robust, reliable, doesn't give a hot-mic, and only transmits on the correct side of the radio. I was able to get audio transmitting via the PTT command, but highly intermittently and seemingly as a side-effect not as correct behavior.

    Here is a little Ruby program for Linux that will transmit test.wav with the radio in sysop mode on /dev/ttyS0. It:

    • Enables ptt with rts=1
    • Plays test.wav by shelling out to the aplay command (sound card for the radio is #3)
    • Disabled PTT with rts=0

    Code:
    #!/usr/bin/env ruby                                                                                                                                                                                                                                                    
    require 'serialport'
    
    s = SerialPort.new('/dev/ttyS0', 9600, 8, 1, SerialPort::NONE)
    # Ensure RTS is 0, it can be 1 on init                                                                                                                                                                                                                                 
    s.rts=0
    
    begin
      s.rts=1
      `aplay  --device=hw:3,0 test.wav`
    ensure
      s.rts=0
    end
    
     
  2. W7UUU

    W7UUU Principal Moderator Lifetime Member 133 Administrator Volunteer Moderator Platinum Subscriber Life Member QRZ Page

    Wow - nicely done!

    Dave
    W7UUU
     
  3. TJNII

    TJNII QRZ Member

    A few more notes:

    - The serial CTS line is asserted when transmitting, both via serial RTS and via the mic. Audio does not appear to loopback, but I have not fully tested for loopback audio.
    - The serial CTS line is asserted whenever RF squelch is broken, regardless of CTCSS/DCS settings.
    - If receive CTCSS/DCS is configured the audio out will be muted unless correct CTCSS/DCS is received.
     

Share This Page

ad: vanity